Tu servidor está ejecutando la versión 5.1.2 de PHP, pero WordPess 3.6 necesita, al menos, la versión 5.2.4.